-
mysqldump导出导入所有库、某些库、某些表的示例
所属栏目:[MySql教程] 日期:2022-04-04 来源:DaWei
mysqldump导出导入所有库、某些库、某些表的例子: 1 导出所有库 mysqldump -uusername -ppassword --all-databases all.sql 2 导入所有库 mysqlsource all.sql; 3 导出某些库 mysqldump -uusername -ppassword --databases db1 db2 db1db2.sql 4 导入某些[详细]
-
MySQL Binlog三种格式介绍及剖析
所属栏目:[MySql教程] 日期:2022-04-04 来源:DaWei
MySQL Binlog三种格式介绍及剖析: 一.Mysql Binlog格式介绍 MySQL binlog日志有三种格式,分别为Statement,MiXED,以及ROW! 1.Statement:每一条会修改数据的sql都会记录在binlog中。 优点:不需要记录每一行的变化,减少了binlog日志量,节约了IO,提高[详细]
-
MySQL GTID复制中断修复步骤
所属栏目:[MySql教程] 日期:2022-04-04 来源:DaWei
slave中出现错误: 2020-04-09T07:40:18.719203Z 16 [ERROR] Slave SQL for channel : Could not execute Write_rows event on table mytestdb.t1; Duplicate entry 6 for key PRIMARY, Error_code: 1062; handler error HA_ERR_FOUND_DUPP_KEY; the event[详细]
-
doDBA tools,崭新的MySQL实时性能监控利器
所属栏目:[MySql教程] 日期:2022-04-04 来源:DaWei
doDBA tools,全新的MySQL实时性能监控利器 操作系统及MySQL数据库的实时性能状态数据尤为重要,特别是在有性能抖动的时候,这些实时的性能数据可以快速帮助你定位系统或MySQL数据库的性能瓶颈,就像你在Linux系统上使用「top,sar,iostat」等命令工具一[详细]
-
MySQL存储过程详解 mysql 存储步骤
所属栏目:[MySql教程] 日期:2022-04-04 来源:DaWei
mysql存储过程详解 1. 存储过程简介 我们常用的操作数据库语言SQL语句在执行的时候需要要先编译,然后执行,而存储过程(Stored Procedure)是一组为了完成特定功能的SQL语句集,经编译后存储在数据库中,用户通过指定存储过程的名字并给定参数(如果该存[详细]
-
mysql can t start dues to the disk space is full
所属栏目:[MySql教程] 日期:2022-04-04 来源:DaWei
use ./mysqld_safe --user=mysql start mysql. The mysql can not start. There are much mysql restart info show on the screen always. And can not find the /var/lib/mysql/mysql.sock file. The reason: Then find the space is full. So the mysql[详细]
-
global_buffers优化
所属栏目:[MySql教程] 日期:2022-04-04 来源:DaWei
对于global_buffers,可以理解为Oracle的SGA,用于在内存中缓存从数据文件中检索出来的数据块,可以大大提高查询和更新数据的性能,主要包括以下几个参数组成。 1、innodb_buffer_pool_size 这个参数是InnoDB存储引擎的核心参数,默认为128MB,这个参数注[详细]
-
MySQL 5.7 performance_schema库和sys库常用SQL
所属栏目:[MySql教程] 日期:2022-04-04 来源:DaWei
performance_schema库常用SQL: 查看没有主键的表: SELECT DISTINCT t.table_schema, t.table_name FROM information_schema.tables AS t LEFT JOIN information_schema.columns AS c ON t.table_schema = c.table_schema AND t.table_name = c.table_name[详细]
-
Linux环境MySQL5.6安装实践
所属栏目:[MySql教程] 日期:2022-04-04 来源:DaWei
MySQL的安装相对于Oracle来说非常简单,个人觉得与TimesTen的安装配置更为接近,而且后面的Master-Slave或Master-Master集群配置更为简单,甚至比TimesTen的ASP/Active-Active/Active-Standby配置都比TimesTen还要简单,不过MySQL涉及的初始化参数还是比较[详细]
-
如何绘制生产管理流程图,教你快速绘制流程图
所属栏目:[MySql教程] 日期:2022-04-04 来源:DaWei
生产管理又称生产控制,是指对企业整个生产系统设置和运行进行各种管理的工作。以往工作中,我们花费大量时间写生产管理流程介绍,还要确保各个环节是否有重复和多于事项。随着科技发展,各种管理软件可以轻松帮助企业实现自动化办公。尤其是在企业生产过[详细]
-
怎样通过以太网远程访问PLC 较简单的方法
所属栏目:[MySql教程] 日期:2022-04-04 来源:DaWei
一般的 PLC设备 数据通讯 在条件允许的情况下 都采用有线的方式进行,如果 PLC设备距离中控室 距离较 远 , 那布线就相当 麻烦,为 了 解决这个问题, 我们推荐 采用新的 组网 方案: 使用零遁 的 4 G 智能网关 可以远程实现 plc与电脑编程软件 、 与电脑[详细]
-
mysql,出现同步停止的错误的处理
所属栏目:[MySql教程] 日期:2022-04-04 来源:DaWei
因 Duplicate entry 或 非正常关闭mysql, 出现同步停止的错误时,可执行下列命令跳过错误log,从错误log下一条继续同步: mysql SET GLOBAL SQL_SLAVE_SKIP_COUNTER=1; mysql slave start; 非正常关闭mysql而导致的错误log 应该不会太多(有次我手动恢复了8条[详细]
-
MySQL使用pt-archiver归档历史数据
所属栏目:[MySql教程] 日期:2022-04-04 来源:DaWei
pt-archiver可以将表按照指定条件归档到历史数据库中,也支持文件导出,对于归档清理线上历史数据非常方便。 如果要归档表的数据到历史数据库的表中,需要预先在历史数据库中创建表结构。 (1) 按照条件归档表中的历史数据到历史数据中,同时在本地生成归档[详细]
-
MySQL内存占用计算公式
所属栏目:[MySql教程] 日期:2022-04-04 来源:DaWei
MySQL最大可使用内存(M): select (@@key_buffer_size +@@innodb_buffer_pool_size + @@tmp_table_size + @@max_connections*(@@read_buffer_size + @@read_rnd_buffer_size + @@sort_buffer_size + @@join_buffer_size + @@binlog_cache_size + @@threa[详细]
-
浅谈怎样在UNIX系统下安装MySQL数据库
所属栏目:[MySql教程] 日期:2022-04-04 来源:DaWei
浅谈怎样在UNIX系统下安装MySQL数据库(转)[@more@] CODE: # cd /usr/src # tar -zvxf mysql-3.22.25-pc-linux-gnu-i686.tar.gz (产生 mysql-3.22.25-pc-linux-gnu-i686目录) # cd mysql-3.22.25-pc-linux-gnu-i686 # ./configure --prefix=/usr/local/mysq[详细]
-
mysql解压版运行
所属栏目:[MySql教程] 日期:2022-04-04 来源:DaWei
mysql解压版运行: 1.初始化mysql 解压完后打开命令行(cmd)进入mysql的bin目录输入初始化mysql命令: mysqld --initialize-insecure 2.添加环境变量 复制bin目录如:D:mysql-5.7.21-winx64bin 计算机--属性--高级系统设置--环境变量--系统变量--变量([详细]
-
pt-table-checksum出现的问题
所属栏目:[MySql教程] 日期:2022-04-04 来源:DaWei
今天使用pt-table-checksum检查数据库的一致性, 突然报下面的错误:一脸懵逼,这个语句在其他机器上执行都没问题 检查语句如下:pt-table-checksum h=xx,u=xx,p=xxx,P=xx --databases=xx 报错如下: Cannot connect to MySQL because the Perl DBD::mysql[详细]
-
怎样使MySQL更安全以对抗解密高手
所属栏目:[MySql教程] 日期:2022-04-04 来源:DaWei
怎样使MySQL更安全以对抗解密高手(转)[@more@] 当你连接一个MySQL服务器时,你通常应该使用一个口令。口令不以明文在连接上传输。 所有其它信息作为能被任何人读懂的文本被传输。如果你担心这个,你可使用压缩协议(MySQL3.22和以上版本)使事情变得更难。甚[详细]
-
MyCAT高可用方案和架构
所属栏目:[MySql教程] 日期:2022-04-04 来源:DaWei
MyCAT的优势 基于阿里开源的Cobar产品而研发,Cobar的稳定性、可靠性、优秀的架构和性能以及众多成熟的使用案例使得MYCAT一开始就拥有一个很好的起点,站在巨人的肩膀上,我们能看到更远。业界优秀的开源项目和创新思路被广泛融入到MYCAT的基因中,使得MYC[详细]
-
MySQL限制IP网段范围从远程访问的方法
所属栏目:[MySql教程] 日期:2022-04-04 来源:DaWei
mysqlgrant select,insert,update,create on test.* to test@192.168.8.% identified by 123456; mysqlgrant select,insert,update,create on test.* to test@192.168.9.% identified by 123456; mysqlgrant select,insert,update,create on test.* to tes[详细]
-
MySQL 5.5 -- innodb_lock_wait 锁 等待
所属栏目:[MySql教程] 日期:2022-04-04 来源:DaWei
记得以前,当出现:ERROR 1205 (HY000): Lock wait timeout exceeded; try restarting transaction, 要解决是一件麻烦的事情 ; 特别是当一个SQL执行完了,但未COMMIT,后面的SQL想要执行就是被锁,超时结束; DBA光从数据库无法着手找出源头是哪个SQL锁[详细]
-
innodb_data_file_path和innodb_data_home_dir
所属栏目:[MySql教程] 日期:2022-04-04 来源:DaWei
今天研究下关于mysql数据的相关参数以及innodb引擎下的共享表空间和独立表空间介绍,参数主要包括innodb_data_file_path、innodb_data_home_dir、innodb_buffer_pool_size、innodb_buffer_pool_instances四个参数。 一:首先介绍innodb_buffer_pool_size[详细]
-
MySQL 多表更新的限制
所属栏目:[MySql教程] 日期:2022-04-04 来源:DaWei
在对多表进行更新时,不支持ORDER BY、LIMIT。 mysql update Subscribers2 s,tmp_Subscribers_01 t set s.date=2015-01-01, - s.LastAccessTimeStamp=unix_timestamp(date 2015-01-01) - where s.MSISDN=t.MSISDN and t.id between 1 and 5000 limit 2000;[详细]
-
MySQL 一个特殊的难题
所属栏目:[MySql教程] 日期:2022-04-03 来源:DaWei
通过a进行过滤的数据和通过a和b过滤的数据条数一样,如果要通过索引访问数据select * from table where id1=1 和 select * from table where id1=1 and id2=10 是不是效率一致? 简易分析 首先对于数据查找,首先第一步是进行innodb层数据的定位(也就是从[详细]
-
之于mycat读写分离主从切换策略的调研
所属栏目:[MySql教程] 日期:2022-04-03 来源:DaWei
当从库宕机后,读请求会全部转移到主库上,对业务无影响。 1、当主库宕机后 目前,我们的writehost只设置了一个主库,当主库宕机后,通过mycat的 读写请求会全部报错,如下所示: 读请求: mysql select * from t1; ERROR 1184 (HY000): 拒绝连接 写请求:[详细]
